[cvsnt-dev] build failure for using Gentoo's portage

David Somers dsomers at trevezel.com
Fri Feb 18 17:55:45 GMT 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I've just tried to build version on my Gentoo Linux system and
it failed :(

I've wrapped the build process into Gentoo's portage system, and for all the
previous releases it has worked perfectly... but now something has happened
that's broken it.

It looks like xdiff is causing the problem:

Making install in xdiff
make[1]: Entering directory
make[2]: Entering directory
/bin/sh ../mkinstalldirs /var/tmp/portage/cvsnt-
 /bin/sh ../libtool --mode=install /bin/install -c  ext_xdiff.la
libtool: install: error: cannot install `ext_xdiff.la' to a directory not
ending in /usr/lib/cvsnt
make[2]: *** [install-libLTLIBRARIES] Error 1
make[2]: Leaving directory
make[1]: *** [install-am] Error 2
make[1]: Leaving directory
make: *** [install-recursive] Error 1

!!! ERROR: dev-util/cvsnt- failed.
!!! Function einstall, Line 524, Exitcode 2
!!! einstall failed
!!! If you need support, post the topmost build error, NOT this status

Any enlightenment would be appreciated.

Cheers from (freezing and snow-covered) Luxembourg,


More information about the cvsnt-dev mailing list