[cvsnt-dev] build errors on Fedora 9

Scott.J.Borton at Seagate.com Scott.J.Borton at Seagate.com
Wed Dec 3 17:21:06 GMT 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


That solved the problem...put the three lines at the end of cvsapi.h and it
now builds and installs.  Thanks!

- sjb -
Scott Borton

             "Arthur Barrett"                                              
             <arthur.barrett at m                                             
             arch-hare.com>                                             To 
             Sent by:                  "Andreas Tscharner"                 
             cvsnt-dev-bounces         <andy at vis.ethz.ch>,                 
             @cvsnt.org                <cvsnt-dev at cvsnt.org>               
             No Phone Info                                              cc 
                                       Re: [cvsnt-dev] build errors on     
             12/03/2008 01:15          Fedora 9                            


> I have a report from an Ubuntu developer that tries (apparently) with
> gcc-4.4 and this causes the same error.
> #ifdef HAVE_LIMITS_H
> #include <limits.h>
> #endif
> at the top of email_trigger.cpp and info_trigger.cpp should fix this.
> Arthur: Shall I commit this small fix (To
> CVSNT_BRANCH_2_5_04_3236 and
> merge to CVSNT_2_0_x)?

I think it belongs somewhere else, eg: cvsapi.h, so all triggers
(including 3rd party triggers) automatically get the definition.

Why doesn't this bug occur with gcc 4.1?  Where is gcc 4.1 finding the
PATH_MAX that gcc 4.4 is not?


Arthur Barrett
cvsnt-dev mailing list
cvsnt-dev at cvsnt.org

More information about the cvsnt-dev mailing list