[cvsnt-dev] Help using a manual build of cvs

Eric B. ebenze at hotmail.com
Mon Jul 6 22:13:49 BST 2009

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

> Something is completely broken on your VS.NET install:
> > libdiff.lib(regcomp.obj) : warning LNK4229: invalid directive 
> > '/manifestdependency:type='win32'
> > name='Microsoft.VC90.CRT' version='9.0.21022.8' 
> > processorArchitecture='x86'
> > publicKeyToken='1fc8b3b9a1e18e3b'' encountered; ignored
> Visual Studio .NET 2003 should only compile against C RunTime VC71. CRT 
> VC90 indicates you've uused Visual Studio 2008.
> > cvs.exe complains that libxml2.dll and msvcr80.dll were missing,
> Executables compiled with Visual Studio .NET 2003 should only require C 
> RunTime msvcr71.dll, msvcr80 indicates you've used Visual Studio 2005.


After reading your and Tony's emails, I decided to flush everything and start all over.  I uninstalled VS 2008 from my machine altogether and deleted my entire 2_0_x tree, and did a complete checkout on it again.  I then opened the soln in VS 2003 (Version 7.1.3088).  I tried to compile the project in Release mode.


First thing I noticed is that cvsapi does not have libxml2.lib as a dependency in the Release configuration; only in Debug.  So had to add that in for it to compile properly.  I also removed the oracle_database from the build configuration and removed it as a dependency from cvsnt project.


Next I rebuilt the entire solution in Release mode.  Went to a cmd prompt and tried cvs -version.  Again it complained that it was missing libxml2.dll, so I copied it from cvsdeps/x32/libxml2/bin/libxml2.dll into the winrel/ directory.  


Once again it complains that it is missing msvcr80.dll.


This time, I figured it might be something wrong with libxml2.dll.  So I found an old copy of libxml2.dll and copied it into the winrel directory, and presto.  This time I am able to get cvs -version to work.


Does that mean that the copy of libxml2.dll that is in cvsdeps is the wrong one?  Was that built using a newer version of VS?


More testing to come tomorrow to see if I can finally get this up and running, but heading in the right direction.  Although would love to know why the cvsdeps/x32 version of libxml2.dll isn't working.








Attention all humans. We are your photos. Free us.

More information about the cvsnt-dev mailing list