[Cvsnt] Commit fails for one file

Bo Berglund bo.berglund at telia.com
Wed Dec 5 01:32:34 GMT 2001

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I have a repository problem (first real problem in 9 months).
It is like this:
In a module there are a bunch of source files, but we also have
committed the exe target file (as binary). We do this routinely
because we find that it is often very hard to check out the module and
then set up a compiler environment capable of creating the target
file. Much easier to just check out the exe to the tag we need.
Anyhow, this has worked great for a long time in many modules, but now
a problem has surfaced.

Whenever I try to commit a new revision of this exe file WinCvs (1.2)
hangs waiting for something that never happens. The fish swim and I
wait forever...

The only way out here is Task Manager because if I try to stop the
operation with the red stop button nothing happens and if I try to
close WinCvs it refuses because of the ongoing operation.
In the repository where CVSNT (1.10.8) works I now find the following
wrkctr.exe,v - size approx 4.5 Mb (this is the previous revision)
,wrkctr.exe, - size approx 5.2 Mb (probably the new revision)
It looks like CVSNT is creating the ,wrkctr.exe, file as a temp file
and then at the end fails to do what it needs to the original file
(presumably killing it and replacing with the temp file.

What is going on and what can I do to cure this?
I have tried restarting the CVS service, manually moving the temp file
out etc but nothing seems to help. There are no lock files in the
repository to blame either.

Cvsnt mailing list
Cvsnt at cvsnt.org

More information about the cvsnt mailing list