[Cvsnt] problem with pserver/ntserver

Matt Harp mharp at seapine.com
Thu Dec 27 15:30:38 GMT 2001

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I'm trying to setup the pserver/ntserver connection on my Cvs-NT install,
but for some reason none of it is working.

I have the server and client installed on the same machine. I went into the
config and .#config files in my CVSROOT dir and uncommented the
SystemAuth=yes line so that it would use the NT accounts for authentication.

Now, I try the following from the cmd-line.

cvs -d :pserver:harpm at HARPM:c:\cvs_root history -a -e

my computer's name is HARPM, my NT account is names harpm, and the root is
at c:\cvs_root (also shared as \\harpm\cvs_root). So this all looks good to
me, and matches the format given in the server readme file.

But i get the following list of errors

cvs history: CVSROOT (":pserver:harpm at HARPM:c:\cvs_root")
cvs history: requires a path spec
cvs history:
cvs history: [:(ext|server):][[user]@]host[:]/path
cvs [history aborted]: Bad CVSROOT.

what does path spec mean? I also tried to point to the root like
"\\harpm\cvs_root" but get the same error. If I change the direction of the
slashes, I get one simple error of, "//harpm/cvs_root: no such repository".

If I try the ntserver like this.

cvs -d :ntserver:HARPM:c:\cvs_root history -a -e

I get these errors

cvs history: unknown method in CVSroot: :ntserver:HARPM:c:\cvs_root
cvs [history aborted]: Bad CVSROOT.

Anyone know what I'm doing wrong? Your help would be greatly appreciated.

-matt harp
mharp at seapine.com

Cvsnt mailing list
Cvsnt at cvsnt.org
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook