[cvsnt] CVSNT Can't work with Eclipse?

Raymond Zhang zhangxf at hotmail.com
Thu Dec 26 07:21:35 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hi all,
I'm using CVSNT (build 63) and eclipse M4 (i tried M3 too).  I have
the CVS server as follows:
:pserver:test at localhost:D/test_repository/testroot

Eclipse can establish the connection and authenticate the use "test".  But
once I double clicked on "HEAD" in CVS Repository view, the server responded
"cvs [server aborted]: cannot find .: No such file or directory

After tracing by TCP Spy, I find eclipse is actually doing a "cvs update -d
." first before "cvs co -c" to retrieve the modules.  And the behavior of
cvsNT is "cvs update -d ." will always failed with the above error message.

I tried typing command "cvs update -d ." in my command, I see the same error

My question is:
1.  Is that error message a desired way for cvsnt to respondto "cvs
update -d ." command or is that a bug?
2. Is there any way to work around this?

Thanks in advance!


Raymond Zhang

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook