[cvsnt] Re: CVSNT Can't work with Eclipse?

Shepherd chgg at shinewaysoft.com
Fri Dec 27 01:45:56 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am using eclipse too, and I use it for tagging and branching too. If one
user creats a branch, the others can't see the branch, I don't know if it is
a problem.
At other time, it works well.
I use prefix, set in CVSNT service control panel.
I use :ntserver: protocol, and connet by eclipse using :pserver: protocol,
don't know why, but this works fine.
Hope helpful.


----- Original Message -----
From: "BHarriger" <bharriger-removethis at spam-me-not.austin.rr.com>
Newsgroups: support.cvsnt
Sent: Thursday, December 26, 2002 9:14 PM
Subject: Re: CVSNT Can't work with Eclipse?

> On Thu, 26 Dec 2002 15:21:35 +0800, Raymond Zhang wrote:
> > Hi all,
> > I'm using CVSNT (build 63) and eclipse M4 (i tried M3 too).  I
> > configured
> > the CVS server as follows:
> >:pserver:test at localhost:D/test_repository/testroot
> > Eclipse can establish the connection and authenticate the use "test".
> > once I double clicked on "HEAD" in CVS Repository view, the server
> > "cvs [server aborted]: cannot find .: No such file or directory
> > After tracing by TCP Spy, I find eclipse is actually doing a "cvs
update -d
> > ." first before "cvs co -c" to retrieve the modules.  And the behavior
> > cvsNT is "cvs update -d ." will always failed with the above error
> > I tried typing command "cvs update -d ." in my command, I see the same
> > message;
> > My question is:
> > 1.  Is that error message a desired way for cvsnt to respondto "cvs
> > update -d ." command or is that a bug?
> > 2. Is there any way to work around this?
> > Thanks in advance!
> > Thanks
> > Raymond Zhang
> I use CVSNT with Eclipse/WSAD just fine.  Granted, the CVS plugin in
> Eclipse isn't that great (doesn't properly show branches, for example), it
> works fine for simple operations on the head stream.  I simply use another
> client for more advanced uses.  (Such as tagging and branching)
> Get rid of your repository prefix and all should be well.  When you
> your connection string should look like this:
> :pserver:test at localhost:D:/test_repository/testroot
> where your repository is physically stored on the D: drive of the CVS host
> server and is the directory/subdirectory /test_repository/testroot.
> HTH,
> Brian

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook