[Cvsnt] Upgrade problem from beta 4 to beta 6

Bo Berglund bo.berglund at telia.com
Thu Jan 31 19:29:18 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

now you got me....
I just went to verify the functioning of the prefix and I found that
the version I had built on Jan 28th actually does not work as the one
I had a few days earlier did. Something has broken the prefix
So I updated the cvsnt module just now and recompiled and tested
again, and now it does work, albeit a bit strangely:
My repositories sit in F:/CVSREPO and are

If I use the control panel applet to set the prefix and navigate to
the top of the disk F: then this is shown:
Prefix = F:/

If I set the Prefix one level up by navigating to CVSREPO I see this:
Prefix = F:/CVSREPO
Root0 = /BOSSE
Root1 = /HW

Note the difference in the number of / used after F:!

But even so this works now.

So I changed Prefix to F: in the registry and tried checking out my
module, still works as above.
But with Prefix = F:/ there is an ERROR if I use root = CVSREPO/BOSSE
so it seems like CVSNT or cvsservice removes the trailing / of the
prefix if there is one (like after selecting the disk root) and then
tacks on the supplied root. This means the root must always start with
a / char no matter what is set as Prefix.

Kari, if you like I can email you the executables after my build from
the latest sources, this puts you ahead of the beta release, but of
course there is no guarantee since Tony may have a few other bugs
still to hunt down...


On Thu, 31 Jan 2002 17:54:51 +0000 (UTC), "Kari Hoijarvi"
<hoijarvi at me.wustl.edu> wrote:

>OK, could you please tell me how I get the prefix to work.
>for me, it just does not as it used to in Beta 4.
>Please fix the entries here:
>CVSROOT=:pserver:hoijarvi at
>I have tried
>prefix=F: root=/SCM
>prefix=F:/ root=SCM
>prefix=F:/ root=/SCM
>"no such repository is the answer. I cannot check out.
>root F:\SCM without prefix is what I have to use.
>thanks, Kari
>-----Original Message-----
>From: cvsnt-admin at cvsnt.org [mailto:cvsnt-admin at cvsnt.org]On Behalf Of
>Tony Hoyle
>Sent: Thursday, January 31, 2002 11:24 AM
>To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
>Subject: Re: [Cvsnt] Upgrade problem from beta 4 to beta 6
>On Thu, 31 Jan 2002 17:16:46 +0000 (UTC), bo.berglund at telia.com (Bo
>Berglund) wrote:
>>Basically the Prefix will be added up front to whatever root comes
>>along to CVSNT from the client. Then it is compared to the RepositoryX
>>entries in the registry. So if you have Prefix set to F:/ and connect
>>using /SCM obviously the full root will become F://SCM which does not
>>compare to the Repository0 entry and is not existing on the disk
>>But if you change the Prefix to F: and use the same client root then
>>you are just fine...
>cvsnt already takes care of this for you.... It'll work however you do

(Bo Berglund, developer in Sweden)
Cvsnt mailing list
Cvsnt at cvsnt.org
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook