[cvsnt] The -m option in commit command doesn't work

Tiago Manuel Nogueira Fernandes TNFernandes at montepiogeral.pt
Wed Nov 6 18:17:48 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I'm having a problem with CVS for NT. After checking out files and
changing them, I try to do a 'cvs commit -m "Some Message" file(s)' but
cvs doesn't check in my changed files.

If I use the commit command without the -m option, cvs pops up a notepad
window to enter the change message. When I close it, cvs checks in the
file (as it should do).

My main goal is to checkin a file non-interactively (in an Ant build

I've tried to use the -F <filename> option, but it doesn't worked too.

I've tried also to use the -e global option and the $CVSEDITOR
environment variable to point to a batch file that writes to the temp
file created by cvs when checking in, but cvs tells me that the file is
unchanged and stops, asking for user input (abort, continue, etc). I
thought that, somehow, it could be from the batch file. Then I made a
simple C program that writes to the temp file. Same results, cvs says
that the file is unchanged (althought it is changed - some lines

CvsNT version (cvs -v):
Concurrent Versions System (CVSNT)  (Build 57j) (client/server)
OS version:
Windows 2000 Professional SP2

Well, I'm blocked. If anyone knows something about this problem, or is
using the same configuration than I and the -m option is working, please
let me know.

Thank you.

Tiago Fernandes

P.S. I'm not subscribed to the list, so please when answering (I hope!)
cc to me.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook