[cvsnt] cvs2ntslib.dll

Bo Berglund Bo.Berglund at system3r.se
Wed Oct 2 10:14:40 BST 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Which version of WinCvs are you using?
I hope not 1.2???
Because in the 1.2 days you had to do a lot of fiddling with it after setup to make it work with CVSNT, basically replacing the cvs related files in WinCvs by the ones from CVSNT 1.10.8. I looked for these files before answering the last time, but I have erased them from my laptop disk since we are no longer using this older system.

But when I now go to my CVSNT server and look I can actually find the old installation directory on the server with the 1.10.8 files. And there is a cvsntslib.dll!
If you like I can zip these files and send you in a private email.


-----Original Message-----
From: johna [mailto:john.mlist1 at arrizza.com]
Sent: den 2 oktober 2002 09:36
To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Subject: Re: [cvsnt] cvs2ntslib.dll

"Bo Berglund" <Bo.Berglund at system3r.se> wrote in message
> I don't understand why you need this dll at all. I sure don't have it on
my system
> and I can:
> - Run CVSNT server
> - Run WinCvs 1.3
> - Compile CVSNT
> - Compile WinCvs
When I bring up wincvs, select a file in the right-hand pane, and click on
the toolbar button "Add Selected",
I get two new lines in the log pane:

cvs add x.txt (in directory D:\projects\src\alphacalc)
Error: Unable to load the library cvs2ntslib.dll

> But I can see that there is a project file within cvsgui that is called
> so maybe what you are referring to concerns WinCvs rather than CVSNT?
It's possible...

> Trying to build it results in a list of 76 errors caused by missing header
files thoug.
> I think that this is an outdated file and maybe the dsw file was not taken
out from the
> revision of cvsgui?
> No sight of a cvsntslib though....

I've tried recompiling the cvsntlib.dsw and it compiles fine on my machine,
lots of warnings but the dll is created. I put the dll in the PATH and I
still get the same message.

Then I renamed the cvsntlib.dll to cvsntslib.dll and the message went away.
I got a dialog box asking about my home directory which I filled in (there's
no .cvsrc in there though). The message I got was:

cvs add x.txt (in directory D:\projects\src\alphacalc)
cvs add: unknown method in CVSroot: :ntserver:D:\WinCvsRep\TEST

cvs [add aborted]: Bad CVSROOT.

Garbage collection : purged 14 allocations

*****CVS exited normally with code 1*****

It seems "better" than before...


cvsnt mailing list
cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook