[cvsnt] CVSWEB on NT - Please help!

David Field fielddr at btconnect.com
Thu Oct 31 01:52:53 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I had the same issue when I first tried to use cvsweb.  The problem appeared
to be caused by perl failing (can't remember the version number as I can't
get to the machine at the moment but will check tomorrow) when the standard
error was redirected to the nul device (the "2>nul" part of the command) --
removing this seemed to allow it to work

Although this worked, the script would then fail when executing any CVS
commands due to it's redirection of the standard error stream to the
standard output (the "2>&1" part of the CVS commands) -- the solution to
this wasn't as nice.  Basically, I modifed CVS to accept a new command line
flag which made it do the redirection internally, added this flag
("--nostderr") to the CVS command lines and removed the "2>&1" redirections

I'm didn't bother trying to track down what the actual cause for this was
(e.g. a bad PERL install) as the above worked

Hope this helps

"Fernando Gomes" <FGOMES at SE.EFACEC.PT> wrote in message
news:mailman.1035999332.23006.cvsnt at cvsnt.org...
I'm using CVSNT on a particular project, with WinCVS and Tortoise CVS
clients without any problem (great tool indeed)!
Now I'm trying to setup web access using cvsweb, using the IIS 4.0 installed
in the CVSNT server PC (NT 4.0 WKST SP6a)
I have read all the readmes and the devguy site, but still can't manage to
make it work... I can see the repositories, choose one and see the modules
in there, but when I select a module I get the good old
Error: Failed to spawn GNU rlog on
for all the files belonging to the module. RLOG is in the machine path. IWAM
and IUSR users are explicitly added with 'full control' permissions on the
repositories (I have 'everyone' 'full control' on all the PC as this is only
a test pole for now, I want to secure it later...). If I call RLOG manually
for one of the repository files it works well...
I've tried to dig a bit on CVSWEB.CGI and found that the problem is in the
function getDirLogs, it never enter in 'while(<fh>)', it seems it has no
output from RLOG, but the open statement doesn't fail!

Anyone has some tips about this? I'm now completely lost... I had managed in
the past to make this work using an Apache server (also on NT), but with
different version of CVSNT and on a different PC...

I also just finished to configure with a different webserver (Apache) on a
different machine, and the result is also the same... It's a nightmare...

Thanks for any help!


Fernando Gomes
EFACEC Sistemas de Electrónica SA
Apartado 3078

Phone: +351 22 9403394
Fax: +351 22 9485428
E-mail: fgomes at se.efacec.pt
Web: www.efacec.pt

This message and any attachment hereof are confidential and may be
privileged or otherwise legally protected from disclosure and may be read,
copied and used only by the intended recipient.
If you are not the intended recipient, please contact the sender immediately
by return e-mail or by collect call +351 22 956 23 00, delete this message
and any attachment permanently from your system. Any review, retransmission,
dissemination or other use of, or taking of any action in reliance upon,
this information by persons or entities other than the intended recipient is
prohibited and may be subject of judicial action.
Please advise immediately if you or your employer do not consent to Internet
email for messages of this kind.
Opinions, conclusions and other information that do not relate to the
official business of this company, and also any computer programs that may
be hidden in this message, shall be understood as neither given nor endorsed
by it, thus being this company not liable for any losses and/or damages
ocurring thereafter.
By reading this message the recipient accepts personal jurisdiction of the
courts situated in the place of this company's registered address.
Thank you for your co-operation.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook