[cvsnt] SSPI and -x = hang

Bo Berglund bo.berglund at telia.com
Thu Feb 27 23:40:00 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

On Thu, 27 Feb 2003 21:26:38 -0000, "Craig Graham"
<craig at twolips-translations.co.uk> wrote:

>I've discovered (through trying to get Tortoise to work) that if I try using
>CVSNT with the -x flag it hangs. It doesn't crash or go unresponsive- if I
>do ctrl-c I get the standard
>cvs [update aborted]: received interrupt signal
>so it's doing something, but I've left one sitting there for 10 minutes or
>so without it actually doing anything. If I try and retrieve a file
>without -x then it works within a second or so.
>The client and server are on XP machines, distant from each other. A
>firewall's in the way but not on either the client or the server machine. I
>opened the one port that seemed to be required, which since unencrypted
>updates are fine seems OK.
>I've tried various builds of, all with the same result.
>I came across what looks to be a similar problem in December; Jerzy
>Kaczorowski, subject "SSPI encryption not working". I can't confirm the
>server side crashing (wouldn't that bring the server down, so subsequent
>unencrypted transactions failed to connect? I don't see that happening) but
>otherwise it looks the same. Has any progress been made yet on this?

There was such a bug in the WinCvs / CVSNT combination a while ago
(maybe WinCvs 1.3.10 or 1.3.11 plus CVSNT before about b70).
But the most recent ones have solved this. I also banged my head
against this problem for a few days until the fix was done.

(Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook