[cvsnt] "No such user" problem

Gregor Kovač gregor.kovac at mikropis.si
Tue Jan 7 09:23:04 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


Today I have installed CVSNT (Build 65) on a Windows 2000 Server.

The FAQ at http://w1.858.telia.com/~u85831169/InstallCVSNT.html shows how to 
set CVS up to use local usernames from Windows accounts.
I have tried to make CVS use passwd file with no success. :(
I have tried SystemAuth=no and SystemAuth=yes, but nothing worked.
I could add users to passwd file, but if they were not aliased to a system 
user they could not log in (getting "No such user" error).

Any idea what I am doing wrong ?

Best regards,

P.S.: I used the default install options.

Dyer, Neil wrote:

> I have to setup CVSNT such that the server and the repository
> storage are on separate machines.  My understanding is that this means
> that the service must run logged on as a domain account (and specifically
> not as
> LocalSystem) in order to be able to access the remote storage.
> I have experimented
> with SystemAuth=no and SystemAuth=yes.
> Any suggestions as to how to make this work will be appreciated.
> Neil Dyer for
> Anite Telecoms Ltd, 127 Fleet Road, Fleet, Hants.  GU13 8PD
> Tel: 01252 775 228, Fax: 01252 775 299
> Email: neil.dyer at anitetelecoms.com
> www.anitetelecoms.com

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook