[cvsnt] can't create temporary directory ...: Permission Deni ed

Bo Berglund Bo.Berglund at system3r.se
Tue Jan 7 17:12:44 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

You should create a new directory c:\cvstemp, normally this directory will get the
needed permissions.
Then use the CVSNT control panel applet to change the temp dir to this new dir.
Stop the service first. Apply the changes and start the service.

Now I think that it will work, but if not then go to the c:\cvstemp dir,
rightclick on it, select properties and security.
Make sure that the list shows Everyone with full control. If not add Everyone.
If Everyone is already there then add the SYSTEM account and give it full control.

On my XP-Pro machine where I run CVSNT also I have no problems and I have not
been forced to add the SYSTEM account to the users for CVSTEMP, so you should
probably be fine.

Note that the c:\windows\temp dir has very restricted access properties, this
is probably why it fails.


-----Original Message-----
From: Shawn Nicholson [mailto:t00kewlman at earthlink.net]
Sent: den 7 januari 2003 17:43
To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Subject: [cvsnt] can't create temporary directory ...: Permission Denied

I've just installed cvsnt for the first time.  I've never used CVS before,
so I've read just about everything trying to figure out what is causing this
problem.  I am running cvsnt v1.11.1.3 (Build 65) on Windows XP Pro.  I am
trying to login with sspi using my own account which is an administator to
the system.

I am getting this message any time I try any commands either from the
command prompt or within WinCVS:
can't create temporary directory C:\WINDOWS\Temp/cvs-serv2872: Permission
Permission denied

I've tried changing it to different paths, paths that I know should have no
restrictions.  I can't come up with any reason why this would be happening.

Anyone have any idea what I'm doing wrong?


Shawn Nicholson

cvsnt mailing list
cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook