[cvsnt] Latest Updates / ampersand modules

Colin Bendell cbendell at point2.com
Tue Jul 15 18:41:10 BST 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am having a similar problem when I use a series of nested -d operations.
This worked under our linux installation, but since moving over to cvsnt, it
has not worked.  This problem manifests itself in the following way:

Modules file:
_jdk141 -d deploy/java tools/java/j2sdk1.4.1
_bin -d deploy/bin tools/bin
manager -d manager phoenix &_bin &_jdk131

The directory structure I expect to get would be:
   + phoenixdir1
   + deploy
       + bin
       + java

However, what I actually get is:
+ manager
   + phoenixdir1
   + deploy
       + bin
           + tools
               + java
                   + j2sdk1.4.1
       + java
           + tools
               + bin

any help would be bery beneficial.


"Kai Bernhard" <kb at brueckmann-gmbh.de> wrote in message
news:mailman.5.1058196729.469.cvsnt at cvsnt.org...
> Tony Hoyle schrieb:
> > There have been no changes with ampersand modules since 2.0.5, which is
> > reported to be working OK.  Presumably you're using a configuration
which is
> > unusual - can you post your modules file?
> >
> > TBH I'd avoid them like the plague - the code that produces them has so
> > exceptions in it now I'm tempted to ditch the whole modules system and
> > it anyway...  it's only a matter of time before something gets
> >
> > Tony
> >
> There is just that one line in my modules file, exactly like
> mod &ampmod1 &ampmod2 &ampmod3 &ampmod4 &ampmod5 &ampmod6 &ampmod7
> &ampmod8 &ampmod9 &ampmod10 &ampmod11
> "mod" itself contains no files and does not even have a folder in the
> repository. Apart from that and maybe the number (11) of ampersand
> modules, I don't think it is an unusal configuration..? Am I making
> mistakes here that just "accidentially" work in 2.0.3?
> When i checkout "mod" with 2.0.3, cvs creates mod, mod\ampmod1,
> mod\ampmod2, ..., mod\ampmod11, all works fine as I expected. Checking
> out "mod" with 2.0.5 and 2.0.6 hangs at the end of ampmod2, giving the
> "something bad" msg and error 50 when creating the crash dump. Today I
> also realized that it checks out ampmod1 to mod\ampmod1\ampmod1 and
> ampmod2 to mod\ampmod2\ampmod2. As you say you didn't change it between
> 2.0.5 and 2.0.6, I guess 2.0.5 will do the same but I didn't notice.
> ampmod1 does not have subdirectories, ampmod2 does.
> There has been a posting on 5th of July "ampersand module not working in
> 2.05", seems to be the same problem. I tried to reply to that, but the
> mail bounced :-( reason: 554 <cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook>: Recipient address
> rejected: Access denied
> I remember there have been problems in 2.0.3 in relation with ampersand
> modules and the -d parameter, reported on this list around may 7th. But,
> as I don't need -d, 2.0.3 works fine for me. I see it is a complex
> issue, and fixing one end may break the other (guess that happened
> 2.0.3>2.0.4/5) - rewriting might be a good idea. If you need any more
> information, or want me to check with current development version, I can
> do that tomorrow. I could also try to reproduce the problem with a
> sample module in a test repository, zip that and mail it to you.
> Kai

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook