[cvsnt] Linux compile error: Is this a Solution or SNAFU?

Starrett, Glen (AZ15) glen.starrett at honeywell.com
Mon Jul 28 00:41:06 BST 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I need some help from someone who knows a bit about Linux / gcc / MAKE.  I'm
trying to compile CVSNT 2.0.8 under RedHat 8 and am getting this:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../lib -I../diff -I../cvsgui       -g
-O2 -c `test -f 'zlib.c' || echo './'`zlib.c
make[3]: *** No rule to make target `../cvsgui/libcvsgui.a', needed by
`cvs'.  Stop.
make[3]: Leaving directory `/home/gstarret/downloads/cvsnt-2.0.8/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/gstarret/downloads/cvsnt-2.0.8/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/gstarret/downloads/cvsnt-2.0.8'
make: *** [all] Error 2

I took a wild guess (after downloading gCVS and making it and still not
finding the needed file) and went into the cvsnt-2.0.8/cvsgui and did a make
there directly--that produced the library file cvsgui.a for me, then I
backed out to cvsnt-2.0.8/ and ran make again and it worked without error.

Is this correct?  If so, sounds like you need to reorder or make a rule to
do that missing step.  If that isn't it, please let me know what I need to

Yes, I'm a total noob to Linux and GCC and MAKE, I'm just trying to muddle
through.  :)


Glen Starrett
glen.starrett at honeywell.com
Senior Systems Architect, Tools & Technology
Project Operations, Honeywell IC

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook