[cvsnt] Can't get SSPI to work (2.0.4)

Craig Barkhouse craig at wanware.com
Wed May 21 21:43:18 BST 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

John Peacock wrote:
> The first three above are FQDN (after a fashion), whereas the last is probably 
> not (since it does not include the domain).  Try adding a line for your 
> workstation name to your C:\WINNT\SYSTEM32\DRIVERS\ETC\HOSTS file and see if 
> SSPI works.

I neglected to mention it, but I did try that earlier.  I also tried specifying the fqdn in the CVS root string.  Neither helped.


I've fiddled with this for another hour now, and I've finally narrowed the problem down as far as possible.  The breakthrough came when I disabled my LAN connection, and SSPI worked fine with the CVS root string ":sspi:craigb:/Home".  So I took a hard look at my TCP/IP settings and found the culprit.  I use an IP alias on my LAN connection (for a reason which is beyond this discussion, but it's needed)  That is, I have two IP addresses, and  This seems to screw up CVSNT's SSPI.  The addresses are stored as a REG_MULTI_SZ value in the registry, incidentally.  It doesn't matter which order the IP addresses are listed.  If I remove either one (thus reducing me to a single IP address), it works.  As I need the second IP address, I will have to stay with ntserver authentication for the time being.

Hopefully this is enough information to lead you to a solution, or else the conclusion that it is not CVSNT's fault.  It's always possible that it's Microsoft's fault.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook