[cvsnt] EMERGENT: help when upgrade to 2.0.11

Guofeng Zhang guofengzhang at visionnex.com
Thu Nov 6 02:13:10 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I tried CVSNT 2.1.11 , the development version. it works as 1.11.1.x, that is, if the vuser directory has existed, when I re-checkout the module, the directory will be UPDATED.

In 2.0.11, if I use this command: 
           cvs co -P biz!vuser           (no -d option)
if the biz!vuser command exists, when I run the above command, the directory is udpated. the problem occurs only when '-d' option is used.

Is it a bug?

-----Original Message-----
From: Glen Starrett [mailto:grstarrett at cox.net]
Sent: 2003Äê11ÔÂ5ÈÕ 23:02
To: Guofeng Zhang; cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Subject: RE: [cvsnt] EMERGENT: help when upgrade to 2.0.11

> I need to check out a module from CVSNT to a new directory. 
> for example, 
>      cvs co -P -d vuser biz!vuser
> I found that when I re-check out the module( re-run the above 
> command) , I get the following message:
>     cvs server: Updating vuser
>     cvs checkout: move away vuser/build.xml; it is in the way
>     C vuser/build.xml
>     cvs checkout: move away vuser/log4j.xml; it is in the way
>     C vuser/log4j.xml
> the file newly modified by others do not checkout.

Looks like there is an existing vuser directory (it is not a new directory).
Make sure you delete it first before retrying your checkout.

Glen Starrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook