SOLVED: Re: [cvsnt] CVSNT - Problems in executing *info scripts under Windows 2003 Server

keeron modi keeronmo at
Mon Nov 10 19:14:10 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to

crap :) Windows 2003 server *by default* gives "cmd.exe" permission to only
admins. It should be given to "everyone" (if you see windows 2k, or xp). So
by giving "everyone" (or in our case a group called cvsusers) permission to
read/execute cmd.exe , it was all ok

- Keeron

"Keeron Modi" <KeeronMo at> wrote in message
news:mailman.158.1068070034.731.cvsnt at
> Hello All,
> I have Windows 2003 Server, latest CVSNT version installed and the clients
> use WinCVS/TortoiseCVS.
> I am playing around with the *info scripts to trigger scripts upon certain
> events. There seems to be some security/permissions issue regard this.
> First about the repository - the repository permissions is based on NTFS
> permissions. Users are in specific groups, and then these groups are given
> write access on their appropiate project (ie. Repository). There is a
> special admins group in which I and other admins are placed.
> I am using loginfo script for starters ($CVSROOT/CVSROOT/loginfo) and have
> this line in it :
> ALL c:\perl\bin\perl.exe "C:\Progra~1\viewcvs-1.0-dev\"
> The script dosent do any thing except print the "Hello". I have two groups
> "project-grp" and "cvs-admins". I've given "project-grp" full read/write
> access to $CVSROOT/CVSROOT/ folder (I know I shouldn't give full access,
> just to test). Also, I've given them the full access on "" which is
> in my program files.
> When A user who is in cvs-admins (local admins) group tried to commit
> anything, the "" executes and prints out "hello".
> When a user who is in "project-grp" tries to commit anything, the
> fails and we get the following error:
> cvs server: Script execution failed: Permission denied
> cvs server: cannot write entry to log filter: c:\perl\bin\perl.exe
> f:\cvsrepo\cm\CVSROOT\
> cvs server: Pre-commit check failed
> cvs [server aborted]: correct above errors first!
> Error, CVS operation failed
> Based on this I thought the user / "project-grp" needs read/execute
> permission to "c:\perl\bin\perl.exe" ... but giving that dosent solve the
> problem.
> The problem does solve when you put the users from "project-grp" into the
> admins group .... But we don't want that - that defies the whole purpose
> setting up admin group, and individual project groups :-)
> Any solutions to this ? I know *info scripts in CVS is a really important
> part. But I havent yet found lot of talks on using this with CVSNT and how
> the permissions go ...
> We don't want to give the cvs users admin rights .... But at the same time
> be able to execute these *info (and other perl/python) scripts.
> Any ideas why this is going wrong ?
> Thanks,
> Keeron
> --------------------------------------------------------------------------
> -
> "Strive for perfection in everything you do, take the best that
> exists and make it better, and if it does not exist then design it."
> Keeron Modi
> KeeronMo at
> Intern - Configurations Management Group.
> Attachmate Corporation

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook