[cvsnt] SSH & an unusual port

Blake McBride blake at integra-online.com
Mon Nov 17 17:35:59 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I have been trying to access a CVS repository for about 10 hours now 
with no success.  I think my main impediment is the fact that the server 
is running ssh on an unusual port.  I can't seem to get cvs to use ssh 
on an unusual port (although I know it is possible since others are 
doing it with eclipse).  Here are my particulars:

Linux running the latest cvs
The SSH server is running on an unusual port

Windows XP

1.  I can SSH into the server without a problem
2.  I can execute cvs server
3.  Others in my organization can run everything without a problem 
through eclipse (& XP)
4.  I have tried the regular cvs for Windows, WinCVS, Cygwin, plink, cvsnt.
5.  I have tried every concevable permutation between root settings and 
environment variable settings.  Nothing works.

Your help is greatly appreciated.

Blake McBride

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook