[cvsnt] Re: Error with 2.0.51a ends with "results may not be correct"

Fish fish at fish-mail.com
Wed Aug 4 15:37:03 BST 2004


>> Now, when the users try to do any CVS operation, they get an error message 
to 
>> the effect of "cvs server: Access denied looking up D:/data/cvsroot/digital 
- 
>> results may not be correct".  I tried creating for them a new cvsroot, I 
>> tried resetting all the filesystem permissions, and still they get that 
error 
>> message.  With an add, they get the error message and then the add goes on.  

>This means that the user doesn't have list/traverse permissions on the 
>directory, so CVSNT is unable to resolve the correct case (it has to do 
>this to keep various parts of the system happy, plus Unix clients).
>
>Tony

Thanks for the suggestion, but that can't be it, or at least there's some 
other contributing factor, because the user group in question has full 
control from the root of the repository on down.

I did a little more troubleshooting yesterday, and I can conclusively say that 
this works fine for people who are members of the local administrators group, 
but does not work for any other user.  The service is running as LOCALSYSTEM, 
by the way.

Are there any local security policy settings that must be in effect for CVSNT 
to function properly?

Fish



More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook