[cvsnt] SSPI Access denied problems [was: Access denied lookingup C:/Data/cvsrepo]

Scott Whitney ScottWhitney at DesignMentor.com
Thu Aug 19 13:25:03 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Flávio & Mike,

Thank you for your ideas and constructive help.  Last night I tried Flávio's suggestion regarding the 'List Folder' permission on every folder above the repository, and it actually worked!  This sounds like something that might want to make its way into an FAQ for installing CVSNT on a Windows server to make the process a little less painful for the next person, but I'm not sure who to contact.  Any ideas?

Thank you again for your terrific help!


-----Original Message-----
From: Flávio Etrusco [mailto:Flavio.Etrusco at atan.com.br]
Sent: Wednesday, August 18, 2004 1:02 PM
To: Scott Whitney
Subject: RE: [cvsnt] SSPI Access denied problems [was: Access denied
lookingup C:/Data/cvsrepo]

Is your repository in an drive more restrict than usual? I had a respoitory on a drive which was unlocked only to Admins, permissions were assigned on a per-directory basis.
This worked fine until I updated to CVSNT 2.0.51a/b/c. Tony talked sometime ago about CVSNT having to list directories to resolve issues regarding name case, so I tried changing this and ended solving it by giving 'List Folder' permission to 'Users' group on every folder bellow (hmm, I mean parent folders) the repository folder.

E.g. D:\services\cvs\<contract_id>

'D:\services\cvs' used to be the repository prefix. I had to add 'List Folder' permission to 'Users' group on 'D:\', 'services' and 'cvs'.

Hope this helps.


> -----Original Message-----
> From: cvsnt-bounces at cvsnt.org 
> [mailto:cvsnt-bounces at cvsnt.org] On Behalf Of Scott Whitney
> Sent: quarta-feira, 18 de agosto de 2004 12:34
> To: Mike Wake
> Cc: CVS-NT Mailing list (E-mail)
> Subject: RE: [cvsnt] SSPI Access denied problems [was: Access 
> denied lookingup C:/Data/cvsrepo]
> Hi Mike,
> No, there is no passwd file in C:\Data\cvsrepo\CVSROOT.
> The contents of C:\Data\cvsrepo\CVSROOT\config are as follows:
> # Set this to `no' if pserver shouldn't check system users/passwords
> #SystemAuth=yes
> # Put CVS lock files in this directory rather than directly 
> in the repository.
> # (Depreciated.  Only honoured if LockServer=none)
> #LockDir=/var/lock/cvs
> # Alternate location of CVS LockServer.  Set to 'none' to disable..
> #LockServer=localhost:2402
> # Set `TopLevelAdmin' to `yes' to create a CVS directory at the top
> # level of the new working directory when using the `cvs checkout'
> # command.
> #TopLevelAdmin=no
> # Set `LogHistory' to `all' or `TOFEWGCMAR' to log all 
> transactions to the
> # history file, or a subset as needed (ie `TMAR' logs all 
> write operations)
> #LogHistory=TOFEWGCMAR
> # Set `RereadLogAfterVerify` to control rereading of the log 
> file after a verifymsg
> #   `always` or `yes` to always reread the log regardless
> #   `never` or `no` (default) to never reread the log
> #RereadLogAfterVerify=no
> As you can see, everything is commented out, so we should be 
> using the "defaults".  My understanding is that the 
> SystemAuth setting defaults to yes, but I'm not sure about 
> the default setting for LockServer.
> Does this shed any light on the possible problem?
> Thanks,
> --Scott

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook