[cvsnt] Binnary diff capability from tortoisecvs

martin cole mj_cole_2000 at hotmail.com
Sun Feb 1 23:37:05 GMT 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

So, I downloaded and installed the latest cvsnt locally, on my XP notebook.

I managed to figure out how to add a file using the command line (easier
than I first thought :)  ) after first creating the module in tortoisecvs.

When I tried to commit however, I got the error, saying that -kB was not

Just for kicks, I copied the cvs.exe and sspi_protocol.dll files over to my
tortoisecvs folder (for some reason, I decided to use sspi instead of local
access for the local repo, but being a test anyway, I didnt care) and found
that it worked like a charm.

So my question is, is this expected behaviour, and is it likely to require
this for all clients that need to commit this file ?

Or have I fooled myself, and cvsnt somehow found the tortoisecvs cvs.exe
first, and I just made it work by placing the correct file in the path ?

If I did the needed thing, in copying over the protocol and exe files, is it
likely that future behaviour will be correct given that modification, or
would I be wise to wait for an offical release of tortoise that includes
this binary capability ?

One last question, is there an admin command that I can send to the cvs
server to convert a file to '-kB' from '-kb', and would it "compress" the
current ',v' file on my server, or simply use the '-kB' diff from this point
forth ?

Excelent work to all developers

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook