[cvsnt] New version of the ViewCvs installer for Windows

Christian Hack christianh at edmi.com.au
Thu Feb 5 23:27:37 GMT 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

> -----Original Message-----
> From: cvsnt-bounces at cvsnt.org 
> [mailto:cvsnt-bounces at cvsnt.org] On Behalf Of Bo Berglund
> Sent: Tuesday, 3 February 2004 10:03 AM
> To: viewcvs at lyra.org
> Cc: 'CVS-NT List'
> Subject: [cvsnt] New version of the ViewCvs installer for Windows
> This is to announce that I have released a new version of the Windows
> installer for ViewCvs.
> URL:  http://w1.858.telia.com/~u85831169/ViewCvsSetup.html
> The new stuff is:
> 1) Uses the latest CVS HEAD version of ViewCvs as of yesterday
> 2) Can now detect and install on Apache in addition to IIS
> 3) Tries its best at setting permissions on various files and 
> folders so it
> will work.
> 4) The installation is built using InnoSetup 4.1.3
> I have tested this installer on my Apache 2.0.47 installation 
> and it seems
> to work out of the box.
> However, I am waiting for reports from the community if there are some
> oversights on my part.

Just tried to install this on a NT4 Server SP6 Box. Here's some things I

1) It gave me no choice as to where I want GnuWin32 installed. So it
then created a Programs directory in the root of C:. Not very nice to
force an install location like that IMO. It did allow me to select a
location for the ViewCVS directory.

2) I run both Apache and IIS on our box. I use and prefer Apache for
most things, but there are few things (like our corporate virus scanner)
that are IIS only. It would seem the installer finds IIS first and stops
there. Can we be given a choice of server if more than one is detected?

3) Currently I am also getting an error during the "Finishing
installatio" phase that says: "Python.exe - Entry Point Not Found - The
procedure entry point CryptEnumProvidersW could not be located in the
dynamic link library ADVAPI32.DLL". This could be due to the fact I
haven't rebooted the machine since installing Python and the extra path
hasn't taken effect. I can't reboot the machine right now, so I can't
easily tell if that's the problem.

If there is something to tell me how to set it up manually in Apache,
can you point me to it. I can't find anything but don't mind editing
config files by hand at all.

Thanks for doing this.


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook