[cvsnt] Re: Unable to correctly import *.tar.gz archives

Bo Berglund bo.berglund at telia.com
Sun Feb 8 22:14:20 GMT 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I was under the impression thta you hade a CVS repository that you
wanted to move to another (CVSNT on Windws) server and thus you had
TARed up the whoöe source repository.
So my answer was about the handling of this, i.e. to get the files
from the TARball usable in the new environment you shuld unpack them
using WinZip *only* after making sure the WinZip (un)smart CRLF
conversion was removed.

But now it seems that for some unknown reason you want the entire TAR
file to be a file you check in to the new repository...
Why you want this is beyond me, but it is perfectly possible. Just add
it binary and commit and you are done.

If a file is "recognized" as unicode, DON'T proceed! Stop right there
and correct that first! If not you will wind up with exactly this
behaviour. It happened to us last week when a developer had updated
our database table diagram (a graphical picture of the relations
between the 80+ tables) and had made a PDF file of it. He added the
file using WinZip and happened to click the wrong button, winding up
with a Unicode add. The PDF file (about 150k) was then committed and
the result was a 1.5K unusable file!


On Mon, 16 Dec 2002 07:45:14 -0800 (PST), Arvind Raman
<arvind_raman_tech at yahoo.com> wrote:

>Hi Bo and others,
>This is regarding one of my previous mail. To which I
>got the response attached below. Well I am not sure if
>my question is really valid or not, but I would like
>to know if it is not possible to import a tar.gz file
>as downloaded from the ftp server directly to the CVS
>When I tried doing so, 
>#1. CVS first recognized the *.gz file as a Unicode
>#2. The RCS file created on the database was just a
>1KB in size whereas the original file was around 300KB
>When the above approach didnt work, I tried unzipping
>and zipping the file back as a Winzip file and then
>things seemed to work perfectly well. Is this the only
>way its going to work ?
>So my reply from work did not appear...
>Well, here goes again:
>This is a FAQ: If you move a UNIX repository using TAR
>and then the
>TAR file is expanded in Windows using WinZip you have
>to make sure the
>default TAR switch in WinZip is cleared..
>Go to Options/Configuration/Miscellaneous/Other
>Find and clear the checkbox "TAR file smart CR/LF
>then retry your expansion of the repository. My bet is
>that now it
>will work. You will still go over the admin files to
>modify settings
>that are UNIX specific.
>On Wed, 11 Dec 2002 07:27:04 -0800 (PST),
>arvind_raman_tech at yahoo.com
>(Arvind Raman) wrote:
>>I posted this query a month ago on the cvsnt mailing
>>list but couldn't get any response from there.
>>of fwding it here to see if anyone here could help.
>>I have been facing issues trying to import *.tar.gz
>>files. When I try importing these file CVS pops up a
>>warning message saying that the files are being
>>imported as unicode files while they are binary.
>>I tried forcing these files to binary and also as
>>unicode in two different experiments, but each time I
>>checked out the file they were different from what
>>used while importing.
>>The problem goes when I extract the file from the .gz
>>archive and zip them back in the winzip format.
>>Is this a know problem and does there exist a
>>to it ?
>>I was trying to import the gawk and the sed archive
>>the .gz format available from
>Do you Yahoo!?
>Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

(Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook