[cvsnt] postcommit running cvs but not picking up the latestchanges?

Samuel R. Neff srnlists at speakeasy.net
Fri Feb 27 15:53:35 GMT 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

So this means I'm SOL?  Would upgrading to the latest version help (2.0.24
-> 2.0.26)?



> -----Original Message-----
> From: cvsnt-bounces at cvsnt.org 
> [mailto:cvsnt-bounces at cvsnt.org] On Behalf Of Tony Hoyle
> Sent: Friday, February 27, 2004 7:23 AM
> To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
> Subject: Re: [cvsnt] postcommit running cvs but not picking 
> up the latestchanges?
> On Thu, 26 Feb 2004 16:01:08 -0500, "Samuel R. Neff"
> <srnlists at speakeasy.net> wrote:
> >When I run the script manually it works fine.  When I run it based on
> >post-commit, it doesn't pick up updates.  I found out that 
> if I do two
> >commits then the post-commit will pick up the earlier 
> updates, so it's just
> >not picking up the newly committed files.
> That's probably the checkout atomicity kicking in - the CVS process
> hasn't finished so it returns the older files instead.
> Not sure why it would do that, though... all the locks should be
> released at that point so I'd expect it to have finished the
> transaction too.
> Tony

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook