[cvsnt] Unix client problems

Erik Weber erikweber at mindspring.com
Thu Jul 1 14:12:12 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hello. I am a unix developer with not a lot of Windows savvy. Forgive me 
if this question comes up a lot. I have done my homework and still 
cannot find a solution.

My client is running cvsnt version 1.11.1 on Windows NT. I am trying to 
connect remotely from the command line client (1.11) on Linux. The 
problem is that I cannot find a way to correctly specify the repository 

The repository is located at "D:\cvsroot".

The problem is that my client requires you to delimit the path portion 
of the connect string with a "/". All the examples, even those that seem 
to be aimed at unix client users, don't seem to regard this fact.

For example, this is from the cvsnt readme:

Note:  UNIX clients interpret a \ as a character escape.  You will need to specify \
	as \\ on UNIX.

	set CVSROOT=:pserver:notes\waynej at goldenrod:d:\cvsroot
	set CVSROOT=:pserver:demo at goldenrod:d:\cvsroot
	export CVSROOT=:pserver:notes\\waynej at goldenrod:d:\\cvsroot

*None* of these appear to be acceptable to the unix client. As I said, 
the path has to start with a "/", not a ":".
The windows cvs.exe client appears to allow this syntax, but the unix 
client does not.

For example, this connect string worked from cvs.exe:

cvs -d :pserver:user at address:d:/cvsroot login

But this is considered a bad CVSROOT by the unix client.

If I use the forward slash:

cvs -d :pserver:user at address/d:/cvsroot login

The CVSROOT is acceptable, but the command fails because the server 
cannot find the repository "/d:/cvsroot".

I cannot seem to get around this forward slash inclusion. I tried every 
type of adjustment to the cvsroot in the connect string I could think of.

So I saw a couple of other solutions mentioned in other cvsnt docs, 
neither of which worked for me, at least at first attempt.

One was to try the double forward slash "//" in place of a colon. This 
won't help -- same problem as above. The problem is not the ":" after 
the "D", it is the initial forward slash that is required by the unix 
client, which causes a "repository not found" error because no paths on 
a windows box start with "/".

Two was to map some sort of logical name to "D:\cvsroot", such as 
"/cvsroot", on the server, so that I could connect from the unix client 
using the logical name rather than the real path. The cvsnt docs show a 
tab where you can set a "repository prefix" in the cvsnt control panel 
applet. Well, my client's cvsnt control panel applet doesn't even have 
the tab shown in the doc -- there is no place to set a "repository 
prefix". There is only a single tab, with controls to stop and start, 
install and uninstall, which protocols to support, and the real paths to 
repositories (e.g. "D:\cvsroot"). Did the client install some sort of 
"lean" version of cvsnt?

I would appreciate any insight on this matter.


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook