[cvsnt] Re: scripts loosing execute permissions

Glen Starrett grstarrett at cox.net
Wed Jul 14 22:59:45 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Lehman, Curtis wrote:
> I have tried using cvs -w commit -f file1 to force a commit after changing
> the permissions to include executable. I also tried editing the shell script
> and 
> touching the files that are binary and then committing the file. In both
> ways
> the commit caused the files to loose the executable setting after they
> were committed. After each try I deleted all the files and checked them out
> again and they did not have the setting set. So, the commit command causes
> the file to loose it's exactable setting and the checkout does not restore
> it.
> I have done all the commands through the command line, no gui. Could 
> CVS be defaulting to read only files somehow and resetting the permissions 
> because of that? Any other ideas greatly welcome. 

Simply touching the file won't change it -- AFAIK when CVS checks the 
null delta, the timestamp isn't even part of the equasion.  What is the 
transcript of your actions?  The following works for me:

	cvs add runme
	cvs ci -m ""
	chmod ugo+x runme
	cvs ci -m "" -f runme
	ls -l runme
	<< lists file with x set>>
	rm runme
	cvs -q up
	<< lists file with x set>>

Is there anything in a .cvsrc or server side cvsrc for you that might be 
overriding any of your settings?  What do you get with a "cvs version"?

Client: Concurrent Versions System (CVSNT) 2.0.41 (client/server)
Server: Concurrent Versions System (CVSNT) 2.0.41 (client/server)

Note that this is all done on Linux, but I don't think that the RCS file 
cares where it is stored.  I can repeat against my other machine if this 
sequence doesn't work for you.

Glen Starrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook