[cvsnt] Re: How do I add a single file?

Siegfried Heintze siegfried at heintze.com
Thu Jul 15 07:35:28 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Ah hah!

Here is what I have done:
(1) I edited my system path variable and moved c:\Program Files\cvsnt to the
beginning of the path variable (ahead of all the cygwin directories) and
rebooted. I don't know if this helped.

(2) I created a new test repository using the init command. This step is
documented in the chm file but it is extremely confusing! The documentation
gives the example of "cvs -d /usr/local/cvsroot init". When I saw that for
the first time, I assumed I was supposed to be using cygwin/bash and use
forward slashes. That is an extremely bad idea if the cygwin cvs client is
incompatible with the CVSNT server.  This time I specified cvs -d
c:\TESTCVSROOT init.  Previously I used the command cvs -d
/cygdrive/c/CONVEX init from the cygwin/bash prompt and it seemed to work.

(3) I use the service control panel to add the new repository. This time, I
take the default name making the name "/TESTCVSROOT" and the root
"C:/TESTCVSROOT". Previously, I made the name and the root identical because
I did not know what I was doing because I never saw the documentation on
this step. This step seems to be missing from the cvsnt chm help file.

(4) I create a temp directory and import 3 files. I then check these files

(5) I used cvs -d :pserver:Siegfried at add
makefile.g77 and it worked! I used a commit and it worked. I edit a file,
save it and checkin worked! Hurray! This has been a brutal struggle!

Now, here is my question: can I salvage my original repository that I
created with the command "cvs -d /cygdrive/c/CONVEX init"? I've tried using
service control panel to change the repository name from C:/CONVEX to
/CONVEX.  Of course, at this time, I abandoned the /c//CONVEX syntax in
favor of the /CONVEX syntax. When this did not work either, I used the
service control panel to switch the name of my repository back again to
C:/CONVEX and tried to use the /C//CONVEX syntax.

I can sure think of a lot things that would improve that documentation in
the cvsnt chm file.


-----Original Message-----
From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org] On Behalf Of
Andreas Tscharner
Sent: Wednesday, July 14, 2004 11:57 PM
To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Subject: Re: [cvsnt] Re: How do I add a single file?

Hi Siegfried, hi Glen,

> Now I try to do an update and:
> Administrator at fasolt /cygdrive/c/Program Files/Apache Group/Apache2/htdocs
> $ cvs up CaseAssessment
> cvs server: Updating CaseAssessment
> cvs server: cannot open directory C:/CONVEXaseAssessment: No such file or
I hope you noted that the sequence "/C" is missing here. In my eyes this 
looks like a bug.
Siegfried, you said, you've changed your repository name from C:/CONVEX 
to /CONVEX, but that it did not help. When you made that change, did you 
also make a new import and a new checkout of your module?

Best regards
Andreas Tscharner                          andreas.tscharner at metromec.ch
Real coders don't comment their code. It was hard to write, it should be
hard to understand.                 -- from the Linux Kernel Mailinglist
cvsnt mailing list
cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook