[cvsnt] Re: Need help to setup CVSNT (cannot add repository)

Glen Starrett grstarrett at cox.net
Sat Jul 24 02:12:39 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

ksa wrote:
> Hello All,
> I have installed CVSNT 2.0.51 on a Windows XP machine. When i tried to add a
> repository from the control panel, it gives me a error saying "Repository
> Initialization failed" and asked me to run a command from the command
> prompt.
> If i run it from the command prompt, i get the following error
> C:\Program Files\cvsnt>cvs init
> cvs init: Error connecting to host An invalid argument was
> supplied.
> cvs [init aborted]: Couldn't connect to lock server
> Can someone point me in the right direction to fix this.
> Thanks

It sounds like LockServer isn't running on your machine.  Make sure 
you've set it to run and that should take care of the lockserver error. 
  The exact service name is "CVSNT Locking Service".

If it is running, then you might have Anti-Virus or a firewall 
interfering with it.  There's also a utility I've seen referenced here 
that fixes the XP networking stack in some cases.

Glen Starrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook