[cvsnt] Re: cvsservice.exe takes 30+ minutes to start and stop

Matt Magurany honkywater at fastmail.fm
Wed Jul 28 16:49:20 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


Weirdest thing... The winsockxpfix didn't work and I tried restarting 
with the service set to manual start, and it still did  the same thing.
So, I went on the assumption that another service was interfering and 
stopped each service one by one until cvsservice.exe startup up normally.

Well, brute force worked and I found that if I stop DHCP client service, 
turn on the CVS services, everything works just fine.

Any idea why it does this? Should I submit a bug?

Thanks for your fast reply yesterday!


Tony Hoyle wrote:
> Matt Magurany wrote:
>> Hey everyone,
>> I'm new to this list and to cvs, and I'm trying to get a cvsnt server 
>> up and running. We've successfully installed it on Windows 2003 Server 
>> Enterprise Edition, but when when we start (or stop) the service, it 
>> takes about a half an hour to start (it stays in 'starting' state 
>> during that time) and I can't restart or stop it in the meantime.  Is 
>> this normal behavior? Has anybody else even had this problem?
> I've seen it take a couple of minutes on a busy server, but never had 
> anything over that.
> The service is an extremely simple program that listens on a port and 
> creates cvs.exe subprocesses on demand.  It polls for its stop signal 
> every 5 seconds, and all it does otherwise is accept connections and 
> create threads (which exist for the life of the cvs.exe process only). 
> There's almost nothing to go wrong... indeed there hasn't been a 
> verified bug report against it in two years :)
> The startup is just a bunch of registry operations, plus initialise 
> winsock and bind to the local sockets... nothing that could take any 
> time (there's not even any reverse lookups in there).
> Try running winsockxpfix and see if that fixes anything... it could be 
> something that's been installed that's holding it up (especially 
> antivirus or firewall).
> Note that XP SP2 RC2 has a bug that the service triggers, causing mayhem 
> if you reboot with the lockserver and service set to autostart... that's 
> apparently fixed in the final release though (so an MS rep assured me, 
> anyway).
> Tony

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook