[cvsnt] Re: 001 FAIL Lock not within repository when trying to add a new file

Glen Starrett grstarrett at cox.net
Fri Jul 30 17:48:15 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Spilker, Jörg wrote:

> Hi,
> trying to add a new file to a module gives me the following error message:
> /work/12spilk/4GL_invekos_alt/FL_P_BEWILL.2002.M/SPER(1)>echo $CVSROOT
> :pserver:12spilk at afa-h1-fs01:/F//VSM/cvs/fb9/4GL_invekos_alt
> /work/12spilk/4GL_invekos_alt/FL_P_BEWILL.2002.M/SPER(0)>cvs add
> f_bewifr02.per                     

Where does the (0) and (1) come from?  Is that just your prompt or part 
of the path?

> cvs [server aborted]: Failed to obtain lock on
> F:/vsm/cvs/fb9/4GL_invekos_alt/FL_P_BEWILL.2002.M/SPER/Attic/f_bewifr02.per,
> v: 001 FAIL Lock not within repository

Did you have the same file name with different capitalization in that 
location before?

> i think the reason is that i moved to file from another module (moved file
> to new module, issued cvs delete and and cvs commit in the old module
> directory and then tried cvs add in the new module directoy). When i create
> a really fresh file and tried to add, it works.

That shouldn't do it, I don't think.

> Server is runnig 2.0.41a and client is 1.11 on Digital Unix.
> Greetings, Joerg 	

Glen Starrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook