[cvsnt] cvsnt web on Windows partially working

libogen . libogen at hotmail.com
Sun May 9 21:43:47 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I hope this is the right place to ask questions about CVSWEB NT :)

I'm working on a local filesystem CVS repo on Win98SE using TortoiseCVS. 
TCVS is a nice client but at times I want an overview of my project, hence 
my interest in CVSWEB NT.

Yesterday I installed CVSWEB NT using cvswebnt_193_2_3.zip into my local web 
server (Apache 2.0.48 + Perl5.6.1 etc.). I have rcsutils including rlog etc. 
(I used rcs57nt.zip) in a directory which is in my path.

After configuring cvsweb.conf & cvsweb.cgi I pointed my browser to 
http://localhost/cgi-bin/cvsweb.cgi/ and it worked. I could then enter my 
project dir and see my sub-dirs but when I browse a dir containing files I 
get an error message as follows:

Error: Failed to spawn GNU rlog on 'c:/cvsrepos/fc/www//my.css,v, 
did you set the $ENV{PATH} in your configuration file correctly ?

I had set the $ENV{PATH} in cvsweb.conf and tried variations eg. reversing 
slashes etc. (I don't think this is the problem though).

I get an entry in Apache's error.log for each file in the repo's dir I was 
trying to view, as follows:

[Mon May 10 04:14:28 2004] [error] [client] rlog: 
c:/cvsrepos/fc/www//my.css,v: warning: Unknown phrases like `deltatype ...;' 
are present.
, referer: http://localhost/cgi-bin/cvsweb.cgi/fc/

And a final entry:

[Mon May 10 04:14:28 2004] [error] [client] rlog: RCS/2,v: No such 
file or directory
, referer: http://localhost/cgi-bin/cvsweb.cgi/fc/

When I run rlog directly eg. "D:\utilities>rlog 
c:/cvsrepos/fc/www//my.css,v", (the result is the same if I use one '/' 
before my.css) the following is output:

rlog: c:/cvsrepos/fc/www//my.css,v: warning: Unknown phrases like `deltatype 
;' are present.

RCS file: c:/cvsrepos/fc/www//my.css,v
Working file: my.css
head: 1.1
locks: strict
access list:
symbolic names:
keyword substitution: kv
total revisions: 1;     selected revisions: 1
revision 1.1
date: 2004/04/09 19:54:33;  author: y;  state: Exp;
Initial revision

As in Apache's error.log, a "Unknown phrases like `deltatype ...;' are 
present." warning appears but as you can see, rlog then continues and 
outputs correctly.

Could it be that CVSWEB NT can't handle this warning and quits or...?

I've searched the web and this mailing list's archives but couldn't find a 
solution so I'm crossing my fingers that someone out there can help me (and 
anyone else with this problem) ;-)


Help STOP SPAM with the new MSN 8 and get 2 months FREE*  

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook