[cvsnt] Error FAIL Lock not within repository - How to solve ?

Pat Galea wlist at dudegalea.co.uk
Thu May 13 16:37:04 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Tony Hoyle wrote:
> All communication with the lockserver is automatically translated to
> the correct case before transmission.  There are no outstanding issues
> on this in 2.0.41 - this is easy to check.. checkout 'cvsroot',
> 'CVSROOT' and 'CvsRoot' and they'll all work just fine.
> The only issue is when people try to bypass the repository prefixes by
> using a path relative to the current drive.  This is hard to fix
> (since 'current drive' means different things at different times) but
> is fixed in 2.0.42 by forcing it to mean whatever drive the cvs.exe is
> on.

I don't understand what you mean by "people try to bypass the repository 
prefixes". In every case where we've had the error, people have just 
been using the repository prefix in their CVSROOT. They've not been 
trying to bypass anything.

It's just that their old CVSROOT contained a repository prefix that had 
the wrong case. When we upgraded the cvsnt server, it no longer worked.

So, for example, my old CVSROOT was:


When we upgraded to 2.0.34, I got the "FAIL Lock not within repository" 
error when trying to do a cvs edit. So I had to change my CVSROOT to:


And then it worked.

Regards, pg

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook