[cvsnt] Re: error-message on commit

kurt ka-2001 at gmx.net
Sat Oct 23 10:06:31 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Don't you loose all the versionhistory if you check it in again ?

If you mean to checkout the project to workspace again, do some changes
and commit then - didn't work - tried it at this moment again.

I also changed the owner from administrator to the current user -
first the file I wanted to commit, then the directories the file
is in (all in CVS-repository) - no change - the same error.

On Fri, 22 Oct 2004 16:18:24 -0700, Bryan Kuhn <bryan at infinityward.com>  

> When I get the error if you just check it in again it works the second  
> time. So don't think its a permission thing.
> Friday, October 22, 2004, 3:11:12 PM, kurt wrote:
>> On Fri, 22 Oct 2004 20:23:01 +0200, Luigi D. Sandon <cp at sandon.it>  
>> wrote:
>>> We are getting the same error after we upgraded to 2.058b.
>>> I.e.:
>>> cvs commit -m "Release 9.0.5" -r DUnit dunit.dpr dunit.drc  
>>> DunitAbout.dfm
>>> DunitAbout.pas DUnitMainForm.dfm DUnitMainForm.pas
>>> GUITesting.pas GUITestRunner.dfm GUITestRunner.pas NGUITestRunner.nfm
>>> NGUITestRunner.pas QGUITestRunner.pas TestExtensions.pas
>>> TestFramework.pas
>>> TestModules.pas TextTestRunner.pas versioninfo.inc versioninfo.rc
>>> versioninfo.res (in directory F:\Projects\Delphi_Libs\DUnit\src\)
>>> Checking in dunit.dpr;
>>> /CVS/Lib/Delphi/DUnit/src/dunit.dpr,v  <--  dunit.dpr
>>> new revision:; previous revision:
>>> cvs [server aborted]: cannot rename file
>>> /CVS/Lib/Delphi/DUnit/src/,dunit.dpr, to
>>> /CVS/Lib/Delphi/DUnit/src/,dunit.dpr,: Permission denied
>>> ***** CVS exited normally with code 1 *****
>>> Some modules works, others not. This one was a new checkout of a module
>>> already existing in the repository (imported with an older version of
>>> compiled under Linux, I believe 2.0.52 or something alike, now cvsnt
>>> runs on
>>> a Windows 2000 server), I was upgrading the library to a new release.
>>> We are using both sspi an pserver. I tried with different server
>>> settings,
>>> especially trying to change the user CVS runs with, but with success.
>> That's exactly what happened to me after upgrading from 2.0.51d to  
>> 2.058b
>> (Permission denied - problem).
>> I think the problem is, that the account under which CvsNT  
>> creates/writes
>> the files changed (in my case from adaministrator to my user-account).
>> You can check this, when you check the owner of the files in the
>> CVS-repository.
>> Files before upgrading had the administrator owner, files created after
>> upgrading have my user-account as owner.
>> As soon as you try to commit changed files, which were created with the  
>> old
>> version (because they are owned by administrator) this problem occurs.
>> My solution was to go back to version 2.0.51d - but maybe you can help  
>> it
>> if
>> you change the owner of (all?) files in the repository.
>> (I don't think any AV is blocking the files - this is to test easily  
>> also)
>> _______________________________________________
>> cvsnt mailing list
>> cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
>> http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook