[cvsnt] Temporary directory problems: cvs [server aborted]: can't create temporary directory

Sean Aitken sean.aitken at gmail.com
Fri Aug 26 14:19:52 BST 2005


I have been using an older version of the CVSNT server for quite some 
time without problem.  Yesterday, I attempted to move the repositories 
to a new server with a new version of CVS for NT.

Our environment is a mixed one, with many different clients. In this 
case, the clients are: cvs command line, Tortoise CVS, Netbeans IDE, and 
a plugin for Visual Studio. We are on an Active Directory domain.

Also, I have searched the mail archives for ideas. I've tried them all. 
Nothing seems to fix my issues.

My first problem is:
I can barely get the pserver proto to work.  Initially I had problems 
getting it to recognize my user. Ultimately, I set the default domain, 
and added my user via: "cvs passwd -a -D DOMAIN username".  This seems 
to have solved that problem.

Anytime I try to perform almost any action that requires the use of the 
temporary directory, I get the following error:

cvs [server aborted]: can't create temporary directory 
R:\CVS_Repositories\_cvstemp/cvs-serv2712: Permission denied

In this case, the operation is a simple update of a single file in the 
root of the repository.  When I use the :sspi: protocol, this works. 
However, as nice as sspi is, it just won't work for many clients.. yet.

The fact that it works with sspi, plus my own monitoring with filemon 
and auditing confirm that permissions on the folder are fine. This is 
something wrong with pserver.

The second problem is:
Very similar to the first.  With sspi configured (as that does parially 
work -- I can use tortiose CVS for checkin / updates), I run the "show 
edited files" command.  The error I get is:

cvs [server aborted]: can't create temporary directory 
D:\cvs\temp/cvs-serv2440: No such file or directory

So, in this case, it appears that CVSNT is looking at a hard coded path 
to find the temporary folder..  ugh.

So, perhaps I should uninstall this build and go back to a previous 
version.  Can anyone confirm these bugs??  Is it possible to fix my 
problems by using a hard coded temp folder?  I feel quite frustrated 
about this, since CVS is so robust... AND the old version of CVSNT 
worked like a champ!

Any advice is greatly appreciated.

Best regards,

More information about the cvsnt mailing list