[cvsnt] Re: repository names and CVSROOT variable in commitinfo script

Oliver Koltermann okoltermann_deletethis_ at gmx.de
Tue Dec 13 08:09:09 GMT 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Oliver Koltermann <okoltermann_deletethis_ at gmx.de> writes:

> Hello Tony & list,
> after changing from physical to logical repository names i found my
> commitinfo script disabled. I have added a script file to the
> checkoutlist of my CVSROOT to put a stylechecker inside. My commitinfo
> contained the line
> ALL C:/Python24/python.exe $CVSROOT/CVSROOT/checkstyle.py
> Which worked well as long as the repository was accessed by a
> connection like :pserver:user at cvs.server:C:/cvsrepo containing a
> physical path. Now the virtual name /repo is used as repository name
> for the same location, but I get the error:
> C:/Python24/python.exe: can't open file '/repo/CVSROOT/checkstyle.py':
>    [Errno 2] No such file or directory
> I changed commitinfo to an absolute path, but isn't there a better
> solution?

I forgot to mention that this is a CVSNT 2.0.58d server. Are there any
changes to this behaviour in newer versions?

I know the version is old, but when I tried to update the last time an
unicode issue hindered me. And as I found out on this list especially
the scripting was in fast movement. Is there a collection of notes
about scripting support and changes between versions?

Thanks for your comments,
O. Koltermann

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook