[cvsnt] Re: Conrtol Panel will not open

Jakob Kruse kruse at kruse-net.dk
Fri Oct 7 09:57:30 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Ah, solved it finally!

I saw a previous post about iconv.dll and using FileMon to track dll's. 
Tried it myself and it turned out that iconv.dll was in fact, on both 
machines, loaded from C:\Windows\System32 instead of from the CVSNT dir 
(disproving that the application run dir is searched first). The iconv.dll 
found in the system32 dir came from a PHP installation, and is apparently 
non-compatible with CVS. Removing it immediately solved the problem with the 
CVSNT Control Panel applet (it even reappeared in the Control Panel), and 
PHP seems to run ok still (I probably removed some obscure functionality 
from PHP there - tough luck).

One problem down!


"Jakob Kruse" <kruse at kruse-net.dk> wrote in message 
news:di5ah9$f7k$1 at paris.nodomain.org...
> Hello everyone.
> Same problem here, on two different machines.
> Have tried with and Control Panel will show one 
> time after install, where I setup the repositories. After that it will not 
> show again. CVSNT dir is first in path. Logging in as Administrator does 
> not help. Changing start dir on shortcut does not help. Clicking on .cpl 
> file in CVSNT dir does not help. On one machine the CVSNT icon has 
> disappeared from the Control Panel completely, although things like 
> TweakUI still show it (enabled) in the list. Event log shows nothing. All 
> other Control Panel applets run fine.
> Problems occured on both machines immediately after installing CVSNT - 
> install, reboot, setup repositories, reboot, can't open cpl - so chances 
> are slim of other programs interfering?
> Both machines are Windows XP Pro SP2, so Home edition is not the problem.
> I am seriously considering downgrading to 2.0 again. I've had nothing but 
> problems with 2.5.
> /Jakob
> "Luigi D. Sandon" <cp at sandon.it> wrote in message 
> news:dhra8o$6nf$1 at paris.nodomain.org...
>> Look at my past posts - a few days ago - about the same problem. If you 
>> have an older DLL - in my case iconv.dll from a TCL installation - in a 
>> folder that comes before the cvsnt one in the path, and that is 
>> incompatible, the control panel applet won't run and no error message is 
>> displayed because rundll32 (used to run applets) does not display any 
>> error message. Try to change the path, moving CVSNT at the beginning, and 
>> see if this helps.
>> -- 
>> LDS

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook