[cvsnt] Commit Issues in

Trevor Leybourne trevor.leybourne at aderant.com
Wed Oct 19 10:19:57 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I've had the following issue raised to me from one of our project managers 
and wondering if anyone else has come across this at all. We use TortoiseCVS 
in conjunction with CVS and are using CVSNT on the server and 
the client is 2.0.58d installed as part of TortoiseCVS 1.8.14.

Heres the comments from the Project Manager:

We think we traced an issue in Tortoise (or CVS) that has been bugging us 
for a while.

The following happened:

  a.. Changed some files
  b.. Did a Tortoise->update from the root
  c.. Did a Tortoise->add contents (just to be sure.) from the root
  d.. Did a Tortoise->Commit from the root
  e.. Commit tells me that everything has been committed.
  f.. Later I get a developer telling me that one of the files has not been 
  g.. I do a Commit from the root again
  h.. Commit tells me there is nothing to commit
  i.. So we search for the file and see that the file is marked as waiting 
to be committed
  j.. We try to commit the file and get a message that the file does not 
exist in CVS
  k.. We do a history on the file and we see that I have committed it some 
weeks ago and nobody else has worked on it
  l.. We tried some scenario's to get it committed but to no success
  m.. In the end we moved the project to get it committed
The scary thing is that I delete the whole root every two weeks to have a 
fresh start. The change to this file could have been lost... I think this 
issue is one that has been bugging us for while. We sometimes have been 
loosing edits and we had no idea how these could have been lost.

Any ideas?


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook