[cvsnt] Setting CVSNT to work with Eclipse?

Tango Development Team gcsaba2 at gmail.com
Sat Oct 29 00:12:24 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I have downloaded CVSNT a couple hours ago, have read the manual and
followed a couple of tutorials I could find on the Internet, but
neither could help me set up a CVS server on Windows XP. I actually
want to access the CVS on a small LAN to write a project with a couple
of people, and we would all be using Eclipse IDE to access it. We
would like to use pserver since we don't want to install ssh or
anything that complicates things, and we don't need security cause, as
I already said, this is on a local network so no one's going to hack
us :)

So this is what I've done:
1) First I've downloaded and installed the latest CVSNT. During
installation it said that it failed to start the cvslocks service, but
as far as I figured this is not essential to running the CVS. I
restarted the computer.
2) After restarting, I openned the CVS control panel and there I could
see that the CVS service is already running, while the CVS lock
service isn't. So anyway, I set the repository configuration:

Server name: localhost
Name: /cvs
Root: /cvs

The directory got initialized, I now have a CVSROOT directory at
C:\cvs. I also set the CVSROOT environment variable to C:\cvs
After this I tried adding a user. My account number on Windows XP is
'Pista', so I tried

cvs passwd -r Pista -a Pista

Entered a password and that's it.

3) Now I wanted to test this. I started Eclipse, openned the CVS
Repositories perspective, and openned the Add new dialog. I entered
the following data:

Connection type: pserver
User: Pista
Password: *********
Host: localhost
Repository path: /cvs
[x] Use Default port

4) This was ok, so now I tried accessing the HEAD, just to see if it
works. I got an error message saying "Socket Exception: Connection

This means that it tried to access the server. If I write something
other than localhost then it would say "Host not found", so obviously
it does try to accedd the server. I checked on which port the CVS
server is listening to, and it's the default 2401. I tried setting
this manually in Eclipse but this didn't produce any results either.

5) The server does seem to work, however. I tried committing a test
directory using WinCVS, and after typing

cvs ls -l -R

in the command prompt, it listed out the contents of the test
directory. However, I specifically need to set Eclipse to work with
CVSNT, and I don't see a reason why it doesn't work specifically with
this one, since it already works ok with two other CVS servers (over
the internet) which also use pserver.

Could someone help me set up CVSNT properly? I'm not an expert on CVS
so please keep this in mind :)

Waiting for your reply,

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook