[cvsnt] Re: Setting CVSNT to work with Eclipse?

Bo Berglund bo.berglund at telia.com
Sat Oct 29 06:44:57 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

On Sat, 29 Oct 2005 01:12:24 +0200, Tango Development Team
<gcsaba2 at gmail.com> wrote:

>I have downloaded CVSNT a couple hours ago, have read the manual and
>followed a couple of tutorials I could find on the Internet, but
>neither could help me set up a CVS server on Windows XP. I actually

Depends, when you say Windows XP you have not qualified your
description, there exists two different versions of Windows XP, Home
and Pro. Only XP Pro is suitable for what you want to do. XP Home is
only usable if you want anyone accessing the repository to be working
on the same XP Home PC as the server is running on.

>So this is what I've done:
>1) First I've downloaded and installed the latest CVSNT. 

Not good enough specification, "latest" is a moving target and noone
will be able to know what you consider as latest. You must give the
full version number of the CVSNT you downloaded (and from where). Just
last night latest bumped up to:

>During installation it said that it failed to start the cvslocks service, but
>as far as I figured this is not essential to running the CVS. I
>restarted the computer.

Wrong, it is very essential. Lockserver *must* be running.
Do you have any antivirus software running on the PC? Known to
interfere with such software as CVSNT.
Also, which installer did you use? There are alternatives around such
as at:

These do *not* use the Windows Installer method and seem more stable
concerning the service installations.

>2) After restarting, I openned the CVS control panel and there I could
>see that the CVS service is already running, while the CVS lock
>service isn't. So anyway, I set the repository configuration:
>Server name: localhost
>Name: /cvs
>Root: /cvs

Bad choice of name. CVS and CVSROOT are reserved names...

>The directory got initialized, I now have a CVSROOT directory at
>C:\cvs. I also set the CVSROOT environment variable to C:\cvs

CVSNT itself oes not use environment variables. Only users do.
And in any case if you do then use the correct syntax. What you
entered is *not* a valid CVSROOT string. Such a CVSROOT setup on the
command line looks like this example:
set CVSROOT=:sspi:mycvsserver:/repository
set CVSROOT=:pserver:user at mycvsserver:/repository

>After this I tried adding a user. My account number on Windows XP is
>'Pista', so I tried

>From a posting made by me only 3 days ago comes this method for adding
users to the CVSNT server with the pserver access method:

Then use the methhod I have used on our server to get the UNIX guys on
board ('cvsserver' and 'repository' should of course be replaced with
the real names):

1. Create two users on the server called CVSUser and CVSAdmin.
2. Give CVSUser permissions on the repository except CVSROOT
3. Give CVSAdmin full permissions on the whole repository
4. Go to a command prompt on a PC on the server
5. Enter this to establish a connection string:
   set CVSROOT=:sspi:cvsserver:/repository
6. Now you are ready to add pserver users:
   cvs passwd -a -r YourUser CVSUser
7. Enter the password for the pserver connection for YourUser
8. To add more users repeat steps 6 and 7 as needed

Note that the names you give the users are completely arbitrary and
will only exist in the CVS context. The user account you alias these
users to must exist and be allowed access to the repository files.
If you want a pserver login to have admin access then you shoulkd
alias him to the CVSAdmin account. This account does not need admin
priviliges on the server PC, just full control on the complete
repository plus listing access to the tree leading down to the top of
the repository.

Now to check that the connection works, go to another command prompt
and enter these commands:
  set CVSROOT=:pserver:YourUser at cvsserver:/repository
  cvs login
  (enter password)
  cvs ls
Now you should get a dir listing of the repository top level, normally
just the dir CVSROOT if it is a new repository, but it show that you
have succeeded in connecting to the server using pserver and an
aliased user.


>cvs passwd -r Pista -a Pista
>Entered a password and that's it.

Wrong, see above.

>3) Now I wanted to test this. I started Eclipse, openned the CVS
>Repositories perspective, and openned the Add new dialog. I entered
>the following data:
>Connection type: pserver
>User: Pista
>Password: *********
>Host: localhost
>Repository path: /cvs
>[x] Use Default port

It is usually a better idea to start investigations *not* bringing in
another piece of software into the picture. Leave Eclipse out for a
while while you  make everything work.

>4) This was ok, so now I tried accessing the HEAD, just to see if it
>works. I got an error message saying "Socket Exception: Connection

What do you mean by "accessing HEAD"? This makes no sense. If what you
did was what you described above then tghere is nothing in the CVS
repository and so there will be nothing to view as HEAD.
Note that HEAD is a position indicator for a CVS module (aka software
project). HEAD indicates the latest revision of all files of the given
module. You have no module...

And you probably also have a firewall blocking the CVS port (Windows

>This means that it tried to access the server. If I write something
>other than localhost then it would say "Host not found", so obviously
>it does try to accedd the server. I checked on which port the CVS
>server is listening to, and it's the default 2401. I tried setting
>this manually in Eclipse but this didn't produce any results either.

2401 does not need setting as it is the default. You have a
non-running server or a networking/firewall/antivirus problem.

>5) The server does seem to work, however. I tried committing a test
>directory using WinCVS, and after typing
>cvs ls -l -R
>in the command prompt, it listed out the contents of the test
>directory. However, I specifically need to set Eclipse to work with
>CVSNT, and I don't see a reason why it doesn't work specifically with
>this one, since it already works ok with two other CVS servers (over
>the internet) which also use pserver.

It *will* work once you set it up properly.
But the first thing is making sure it works properly from a command
prompt on the server PC itself and using the client/server method too.
You have not proven it works from that perspective above. For all I
can determine you have been testing with local access, which does not
say anything at all about the server part....

>Could someone help me set up CVSNT properly? I'm not an expert on CVS
>so please keep this in mind :)

Trying, but you should really read up on CVS first. There are a number
of info sources out there.

(Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook