[cvsnt] Lost keyword expansion setting after multiple merges with added files

Oliver Koltermann okoltermann_deletethis_ at gmx.de
Tue Apr 4 16:25:36 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hello list,

I know that you are going to say that the following is not the usual
way to work. Maybe it's even wrong to do so. But CVSNT's reaction
seems strange to me, too, so I will describe it:

One of our developers claimed that his files lost the binary expansion
mode flag after merging from HEAD into a branch. We tried again with a
"clean copy" and it worked as expected. But when trying the same with
the whole directory we saw the following:

1. cvs update -r Branch -j HEAD

   This merge brought a few *binary* added files into the
   sandbox. They were correctly shown as -kb in WinCVS.

2. cvs update -C file1

   We resetted some files to the clean copy to test again... This step
   is not needed to reproduce the behaviour, only to explain what we
   were trying to do...

3. cvs update -g HEAD (again)

   The binary added files changed to text files!

Again I know that the merging process is the complete "update -j /
commit" cycle and other updates and edits are strictly speaking not
allowed. But as it's not in the hands of CVSNT that this complete
cycle is followed by every user and the text expansion mode can
severely damage binary files, I think this should not happen.

Comments are very welcome.

Best regards,
O. Koltermann

PS: This was CVSNT

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook