[cvsnt] Re: CVSNT not working on my XP home box

Brian Post bpost at 80-20.com
Wed Apr 26 01:57:03 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


To enable ports for windows firewall .

Select Exceptions tab & open TCPIP ports 2401 & 2402. Not sure if 2402 is 
required at all, I added it for for compleness.

"Mark" <lists at mark-arnold.net> wrote in message 
news:mailman.21.1143921536.312.cvsnt at cvsnt.org...
>   Hi,
>   I am having big-time problems getting cvsnt to do anything.
>   After first trying to get it set up with Eclipse without success, I
>   tried to connect the regular commandline cvs client to the server - no
>   success either.
>   Both server and client are running on the same machine.
>   I use version 2.5.03 (Scorpio) build 2260, which I just downloaded
>   today (4/1 -hope this is not some f..ed-up version someone uploaded as
>   april-fools joke???).
>   Here is what I do:
>       C:\Program Files\CVSNT>set
>   CVSROOT=:pserver:mark at localhost:/cvsrepo
>       C:\Program Files\CVSNT>cvs login
>       Logging in to :pserver:mark at localhost:2401:/cvsrepo
>       CVS Password:
>       cvs [login aborted]: Error reading from server localhost: -1:
>   Unknown error
>   This same error message comes back no matter what command I try, "cvs
>   info", for example returns the same "Error reading from server
>   localhost: -1: Unknown error".
>   The repository exists and looks like it was created properly.
>   I tried connection to the server using "telnet localhost 2401". The
>   connection gets set up, and as soon as I type the first character, it
>   gets closed with some weird looking character (it looks just like two
>   cursors that remained on that line. The next line is my regular DOS
>   prompt.
>   When I use the "CVSNT control panel" to stop the CVS server and then
>   try connecting, the connection times out, so it must be CVSNT that is
>   listening to this port...
>   Any idea???
>   Thanks
>   MARK 

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook