[cvsnt] Securing pserver on CVSNT: tunneling with ssh

Damien Moore damien.moore at excite.com
Thu Aug 10 14:07:43 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

 well, I think i sorted out my problem with sserver. it doesn't appear to work unless the client has the same version of CVSNT as the server. I had downloaded tortoisecvs, which used a 22xx build of 2.5.03 of CVSNT,  and wincvs, which i think was using a version 2.0. I'm using v2.5.03 build 2382 on the server. once updated sserver worked fine. is this a known problem or just an idiosyncratic problem with my setup? i felt pretty stupid once i'd realized the problem. now having spent the time to get sserver working i'm still not sure i want to use it. First there is the compatibility issue.  Another problem is if I have port 2401 open, pserver switched off, require encryption turned on, but I accidentally cvs -d :pserver:user"at"repos:/repos login (instead of sserver) its not clear to me that the password isn't being sent down the insecure channel despite the failure of login - i get a nondescript -1 error. (with only require authentication turned on it seems that i can 
actually login with pserver, just can't run commands). Can you confirm that the password isn't being sent down the unsecure channel in this scenario?anyway, despite all my problems I'm very impressed with CVSNT overall and wish i'd set this up a long time ago.thanks for your helpDamien--- On Wed 08/09, Tony Hoyle < tony.hoyle at march-hare.com > wrote:From: Tony Hoyle [mailto: tony.hoyle at march-hare.com]To: damien.moore at excite.comCc: cvsnt at cvsnt.orgDate: Wed, 09 Aug 2006 19:55:07 +0100Subject: Re: [cvsnt] Securing pserver on CVSNT: tunneling with sshDamien Moore wrote:>> With either require authentication or require encryption switched on at > the server> side I can't get cvs to work from the client. For instance, at the > command line on the> client if i type> *cvs -d :sserver:cvsuser"at"server:/cvsrepos command *(where command can > be anything like ls, co etc)> then I get an "end of file" error from cvs.That sounds like a configuration issue - 
the error message for required encryption is very specific.Check the event log on the server for any sserver related messages.Tony

Join Excite! - http://www.excite.com
The most personalized portal on the Web!

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook