[cvsnt] cvs checkout/add ignoring $CVSROOT environment variable?

Bo Berglund Bo.Berglund at system3r.se
Tue Aug 15 15:01:27 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

In a command window:

set CVSROOT=:sspi:redbonemobile:/pom
cvs ls

This should show you the top level modules on repository /pom


set CVSROOT=:sspi:redbonemobile:/pom2
cvs ls

Now the modules listed are those from repo pom2

This has always worked for me and I use it a lot.

Notice that your syntax is wrong. Your environment variable is CVSROOT,

The $CVSROOT designator is used when you want to access the environment
variable from the script command line in for example CVSROOT/loginfo.

But here you are dealing with plain old Windows environment variables
and no $ is used.

Best regards,

Bo Berglund

-----Original Message-----
From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org] On Behalf
Of Nick Duane
Sent: den 15 augusti 2006 15:32
To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Subject: [cvsnt] cvs checkout/add ignoring $CVSROOT environment

I've been using the cvsnt command line client (2.5.03) to play around
cvs while I become familiar with the product.  Wanting to skip typing
the -d 
global option I set the environment variable $CVSROOT to my cvsroot 
(:sspi:redbonemobile:/pom).  I have two repositories; /pom and /pom2.  I

then create a temporary directory and from it run:

cvs checkout -A ./

This gets the CVSROOT info so that I can then add directories to the 
repository (maybe there is a better way, but this is what I came up with
far).  I then create a directory called Eom in my temporary directory

cvs add Eom

The output shows:

C:\data\temp\cvsinit>cvs add Eom
Directory /pom2/Eom added to the repository

Why is it using the /pom2 repository as opposed to /pom?  Using the
control panel I do see that /pom2 does have the 'default repository'
set.  You can't seem to not have a default repository, which I would
would be useful.  When I execute the same statements above but also
the -d global option everything works as expected.

Here is my environment variable:

C:\data\temp\cvsinit>set $CVSROOT

The docs show all the environment variables with the preceeding $, not
if that's just indicating they are environment variables or the variable
actually supposed to have the prepended $.  In any case I tried it both
and without the $ and the behavior was the same.


cvsnt mailing list
cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook