[cvsnt] Repository corruption

Bo Berglund bo.berglund at telia.com
Mon Aug 28 22:56:56 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

On Mon, 28 Aug 2006 23:35:13 +0200, "Sebastian Wangnick"
<sebastian.home at wangnick.de> wrote:

>Dear CVSNT folks,
>please find at http://sebastian.wangnick.de/titeltext.zip one of the
>seemingly corrupt repository files. The error message occurs *only* when
>trying to access (or to compare with) version 1.1 of the file. This is also
>why I did't detect the corruption earlier; in all those strange files I
>detected, the more recent versions are perfectly accessible. Actually, I
>detected the issue only today because (a very thin voice starting here) I
>wanted to give Subversion a look and thus tried to convert the repository to
>Subversion format to have a good size sample. This conversion process threw
>the error messages at me, which I then confirmed by using TortoiseCVS to
>access the respective versions.

I downloaded the file and copied it into one module in my test server.
Then I ran a cvs update on that module in a sandbox expecting the file
to appear, but it didn't...
So I did a trace on the update and the part of the trace dealing with
this file looks as follows:

23:49:32: S ->
23:49:32: S ->
23:49:32: S -> lookup_module2(ModuleYY/titeltext.gif,11)
23:49:32: S -> RCS_parse(titeltext.gif,C:/DATA/CVSREPO/Bosse/ModuleYY)
23:49:32: S ->
23:49:32: S ->
23:49:32: S -> ...returns
23:49:32: S -> rcsbuf_fill(009AF928,00000000,00000000,00000000)
23:49:32: S -> rcsbuf_fill: expanded to 8192
23:49:32: S -> Classify_File (titeltext.gif)
23:49:32: S -> RCS_getversion((null),(null),1)
23:49:32: S -> wnt_stat(titeltext.gif)
23:49:32: S -> _statcore(00000000,titeltext.gif)
23:49:32: S -> vn_rcs=1.3
23:49:32: S -> fileattr_write()
23:49:32: S -> fileattr_free()
Then it proceeds to another file...

Can't make out much of it myself.

Then I ran a cvs log on the file even though it is not in my sandbox:

cvs log titeltext.gif

***** CVS exited normally with code 0 *****

RCS file: /korvKiosk/ModuleYY/titeltext.gif,v
Working file: titeltext.gif
head: 1.3
locks: strict
access list:
symbolic names:
	vor_umstellung_compframe: 1.2
keyword substitution: b
total revisions: 3;	selected revisions: 3
revision 1.3
date: 2006/08/28 13:37:29;  author: wangnick;  state: dead;  lines: +0
-0;  kopt: b;  commitid: 41844f2f1960e3b;  filename: titeltext.gif;
ARWC-Webauftritt: Komplett neue Struktur.
revision 1.2
date: 2005/07/07 21:21:39;  author: wangnick;  state: Exp;  lines: +9
-2;  kopt: b;  commitid: a1442cd9ce22c0f;  filename: titeltext.gif;
Chinesisches Zeichen fuer Glueck korrigiert.
revision 1.1
date: 2005/06/29 19:39:33;  author: wangnick;  state: Exp;  kopt: b;
commitid: d7842c2f8f56cdd;  filename: titeltext.gif;
Erste Version.

So the file is there all right, but it does not get checked out at


(Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook