[cvsnt] cvsnt problem on archlinux - :ext: access method is not available

Jean-Luc Cyr jlcyr at canoe-inc.com
Thu Aug 31 18:53:59 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I've used cvsnt for a while with archlinux (http://archlinux.org). 
Recently after an OS upgrade I found cvsnt is not working anymore while
I've completly rebuild it.  I can't find which dependency cause my
problem.  Here are what happend:

when I try to use it i've got an undocumented (at least for me as i
don't find it anywhere) error.

=== quote ===
[user at host user]# cvs -d :ext:myserver:/directory update
cvs [update aborted]: the :ext: access method is not available on this
=== /quote ===

I don't have any issue with the server and I still access it with older
version of my linux distribution.

I've tried rsh to it from the same host to test cvsnt (server side)

=== quote ===
[user at host user]$ rsh myserver cvs -v

Concurrent Versions System (CVSNT) 2.5.03 (Scorpio) Build 2260

Copyright (c) 1989-2001 Brian Berliner, david d `zoo' zuhn,
                        Jeff Polk, and other authors
CVSNT version (Apr 19 2006) Copyright (c) 1999-2005 Tony Hoyle and others
see http://www.cvsnt.org

Commercial support and training provided by March Hare Software Ltd.
see http://www.march-hare.com/cvspro

CVSNT may be copied only under the terms of the GNU General Public
License v2,
a copy of which can be found with the CVS distribution.

The CVSNT Application API is licensed under the terms of the
GNU Library (or Lesser) General Public License.

Perl Compatible Regular Expression Library (PCRE)
  Copyright (c) 1997-2004 University of Cambridge.
  Licensed under the BSD license.
  See http://www.pcre.org/license.txt

Specify the --help option for further information about CVS
=== /quote ===

any networked methods giving the same result (pserver, server, ...) and
local (file based) cvs access are working properly.

for those knowing archlinux, here is my PKGBUILD file, no specific
options given to build it

=== quote ===
depends=('glibc' 'howl' 'pcre' 'expat')
source=(ftp://myserver.com/sources/cvsnt-${pkgver}.tar.gz cvslockd
cvsnt-pam cvsnt-xinetd)

build() {
  cd $startdir/src/cvsnt-${pkgver}
  unset CFLAGS
  unset CXXFLAG
  ./configure --prefix=/usr || return 1
  make || return 1
  make DESTDIR=$startdir/pkg install
  cd $startdir/src
  install -D -m 0755 cvslockd $startdir/pkg/etc/rc.d/cvslockd
  install -D -m 0644 cvsnt-pam $startdir/pkg/etc/pam.d/cvsnt
  install -D -m 0644 cvsnt-xinetd $startdir/pkg/etc/xinetd.d/cvsnt
        find $startdir/pkg -name '*.la' -exec rm {} \;
=== /quote ===

Jean-Luc Cyr
jlcyr at canoe-inc.com
(418)696-1070 x224

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook