[Cvsnt] Newbie, "No such repository" error on create repository

David Somers dsomers at omz13.com
Tue Jun 6 18:09:19 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

shukla ku wrote:

>   This is the error message I received:
> cvs -d :ntserver:user_name at server_name:\dir_name\testme init
> \dir_name\testme: no such repository

- ntserver as a protocol is depreciated
- use forward not reverse slashes too i.e. / not \

> The "I HATE YOU" was in green text if that means anything.  (Is that
> coming from winCVS or some message
> that winCVS is parroting.  (I want to know who hates me)    : - )

Normally you should never see this message (its part of the underlying cvs
wire protocol)... are you running the latest version of WinCVS (

> I have tried several versions of the above path with no luck.  I even
> tried it without the
> "user_name at server_name".   If I do that I get an "Instruction at
> 0x78003bf
> referenced memory at 0x0000."  error,
> and then winCVS terminates.

Normally, on a Windows-based cvsnt server you would, on the *server*, create
the repository using the cvsnt control panel applet.

Normally, on a 'nix-based cvsnt server you would, on the *server*, create
the repository by using the :local: protocol and giving the destination
path ,
cvs -d :local:/var/lib/cvsnt/repo init

Yes, you can remotely create repositories, but this has to be specifically

David Somers
PGP Key = 7E613D4E
Fingerprint = 53A0 D84B 7F90 F227 2EAB  4FD7 6278 E2A8 7E61 3D4E

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook