[cvsnt] Solved: cvsnt 2.5 vs eclipse 3.2 : slow and/or incomplete repository browsing behavior

Jean-Francois Lamy jeanfrancois_lamy at videotron.ca
Sun Oct 15 21:15:42 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

We ended up enabling the "checkout -n" and "emulate older version" 
checkboxes on our cvsnt server.

So contrary to what we thought, and what the CVSNT FAQ would seem to say, 
Eclipse 3.2.1 is NOT compatible out of the box with CVSNT 2.5.04 unless 
these options are enabled.


"Jean-Francois Lamy" <jeanfrancois_lamy at videotron.ca> wrote in message 
news:efjre9$4h6$1 at paris.nodomain.org...
> Problem: we cannot correctly browse the repository structure in the CVS 
> Repository view of Eclipse 3.2.  We get extreme delays or incomplete 
> results.
> Context:
> - this used to work a couple weeks ago.
> - We have moved our repository to a new partition (to avoid using a 
> compressed drive, see elsewhere in this forum for that saga)
> - We are running, and also tried with same 
> results.
> Detailed behavior:
> - When clicking on the "Branches" item in the Eclipse CVS Repository 
> explorer view to expand a level, there is an *extremely* long delay in 
> getting the list of  our 10 top-level modules (several minutes).   I'm 
> talking about the directories on disk, not the modules file. The progress 
> indicator gets stuck at "Fetching chidren: 37%" for a long, long time.
> - We get the same very long delays when expanding any node in the physical 
> folders tree.
> - There is no such problem when dealing with modules that come from the 
> modules file (as opposed to directories on disk).
> - TortoiseCVS does not have the problem -- fetching of the top-level 
> modules is instantaneous (using the same CVSRoot and the same plink 
> binary)
> When we point Eclipse at our old repository (which was left untouched), we 
> get a somewhat different problem:
> - Only 3 of our 10 top-level module directories appear, and all the 
> virtual modules from the modules files appear. There is no inordinate 
> delay.
> - This is our old repository which used to work fine (albeit on a 
> compressed drive) until MS broke everything.
> Things we've checked:
> - no antivirus on either partition (or indexing or other cycle-gobbling 
> items)
> - NTFS permissions are the same on both structures (xcopy /o /x /e /h /k 
> was used to copy).
> - User impersonation is used, and the user has full Administrative rights.
> - CVSNT server is running under Windows 2000 SP4 fully patched and with 
> the file compression hotfix applied.
> Questions:
> - I enabled the log on the server side to see what was going on.  Even 
> though I've looked at my share of logs in the last 30 years, this one has 
> me stumped. I can't find the commands issued by the clients, or any type 
> of error reporting.  I must be getting old.
> - Eclipse does not log these exchanges on the CVS console, perhaps there 
> is a way to get the output somewhere.  There is a "send debugging to 
> stdout" option in Eclipse, but we haven't been able to find the output for 
> repository browsing anywhere.  Not sure how I would get Eclipse to do the 
> "-ttt" trick.
> Jean-François Lamy
> Teximus Technologies, Montreal, Canada

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook