[cvsnt] Troubleshooting CVS login problems

David Somers dsomers at omz13.com
Tue Oct 17 16:28:18 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Josh Larsen wrote:

> I am running CVSNT 2.5.03 (Scorpio) Build 2382
> I created a repository (F:/CVS/ejrepo).
> Accessing the repository localy (CVSROOT="f:\CVS\ejrepo") I was able
> to add a user and associate that user with my real account.  I double
> checked teh passwd file to make sure, it contains the line:
> scorch:[Passwordish letters here]:Josh
> But I am still not able to login using the pserver or any of the other
> plugin types I have tried so far.
> for example:
> cvs.exe -d ":pserver:scorch at\CVS\ejrepo" login

The \CVS\ejrepo bit  looks wrong... when you configure cvsnt you normally
set up an alias to the actual path (using the cvsnt control panel).

> Outputs:
> Logging in to :pserver:scorch at\CVS\ejrepo
> CVS Password:
> cvs2 [login aborted]: Error reading from server -1: Unknown
> error

Its probably throwing back an error message but the client is a tad

Try adding -ttt to the command line and see if anything useful appears in
the diags.

> Another attempt:
> cvs -d ":sspi:scorch at\CVS\ejrepo" login
> Logging in to :sspi:scorch at\CVS\ejrepo
> CVS Password:
> Can't authenticate - server and client cannot agree on an
> authentication scheme(got '')
> I found a troubleshooting page that recomended running cvsservice.exe
> manually, here is the result of that:
> cvsservice.exe -test
> CVSNT 2.5.03 (Scorpio) Build 2382 (Jul  5 2006) starting in test mode.
> TEMP/TMP currently set to F:\CVS\cvstemp
> Initialising socket...
> Starting auth server on port 2401/tcp...
> Couldn't register with active directory: Configuration information could
> not be read from the domain controller, either because the machine is
> unavailable, or a ccess has been denied.
> CVSNT initialised successfully

You're not doing something silly like running cvsnt on XP Home are you?

David Somers

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook